Все что вы делаете вы делаете на свой страх и риск. Я могу только рекомендовать и не претендую на 100% решение, многое зависит от вашего окружения и прочих настроек. О которых я могу и не догадываться. Дополнение материалов и исправление ошибок приветствуется.

К сожалению в репозитории Debian нет клиента для Zoom. А установка .deb пакета требует подтянуть зависимости, в общем хлопотное для меня это дело, по этому я пошел по следующему пути.

Для установки нам потребуется в первую очередь установить консольную утилиту wget при помощи следующей команды.

sudo apt -y install wget

Далее закачаем последнюю версию пакета Zoom

Снова улучшаем Linux, на этот раз включаем Flash Player.

На самом деле все просто, качаем архив с официального сайта

flashplayer otherversions

для Mozila FireFox

файл flash_player_npapi_linux.x86_64.tar.gz

Извлеките из архива файл libflashplayer.so и разместите его по одному из трех путей:

я выбрал /usr/lib/PepperFlash/ папку пришлось создать, но в этом нет никаких сложностей.

для Яндекс.Браузер

файл flash_player_ppapi_linux.x86_64.tar.gz

Извлеките из архива файл libpepflashplayer.so и разместите его по одному из трех путей:

я выбрал /usr/lib/PepperFlash/ папку пришлось создать, но в этом нет никаких сложностей.

 

 

 

 

Данная информация  полезна, перед обновлением или  после, чтобы узнать что у нас под "капотом" и все ли наши действия возымели успех. Мне надоело искать все эти команды и в пальцы они пока не  вбиты, по этому пусть будет эта шпаргалка здесь.

  • Наименование дистрибутива:

# cat /etc/issue.net

  • Полная информация о дистрибутиве:

# lsb_release -a

  • Архитектура (разрядность) дистрибутива:

# uname -m

  • Версия ядра:

# uname -a

  • Узнать каким компилятором было собрано ядро:

# cat /proc/version

  • Информация о версии дистрибутива, записанная разработчиками:

# cat /etc/*-release

  • Краткая информация о версии Debian, из специально предназначенного для этого файла:

# cat /etc/debian_version

 

Решил в своем Debian 10 обновить Wine до текущей 5 версии. Все как обычно удалил струю версию. После ввода команды установки новой стабильной версии:

# sudo apt install --install-recommends winehq-stable

Получаю загадочную ошибку:

Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming. 

Вот как это все выглядит в окне консоли:

# sudo apt install --install-recommends winehq-stable
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
winehq-stable : Зависит: wine-stable (= 5.0.0~buster)
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

Если у вас возникла такая же ошибка, то вам обязательно надо быть более внимательным как и мне, а также читать далее и не тратить больше время на поиск причин.

На случай если у вас в системе не установлено ещё ни одной из версий Phyton, то ставим обе версии:

Установка Phyton 2:

# apt install python

Установка Phyton 3

# apt install python3

Проверить версию Python по умолчанию, выполнив команду мы узнаем версию:

$ python --version
Python 2.7.13

После установки двух версий Python по умолчанию устанавливается версия 2.7:

Если вам помогла статья или информация была полезной. Благодарность, не должна знать границ.

Популярные метки